nix-config/home-manager/_mixins/desktop/vorta.nix

23 lines
376 B
Nix

{ pkgs, ... }:
{
home.packages = with pkgs; [
borgbackup
vorta
];
systemd.user.services = {
vorta = {
Unit = {
Description = "Vorta";
};
Service = {
ExecStart = "${pkgs.vorta}/bin/vorta --daemonise";
Restart = "on-failure";
};
Install = {
WantedBy = [ "default.target" ];
};
};
};
}