nix-config/nixos/_mixins/desktop/i3.nix
2024-05-23 15:02:20 -04:00

28 lines
482 B
Nix

{ pkgs, ... }: {
# links /libexec from derivations to /run/current-system/sw
environment.pathsToLink = [ "/libexec" ];
services.xserver = {
enable = true;
desktopManager = {
xterm.enable = false;
};
displayManager = {
defaultSession = "none+i3";
};
windowManager.i3 = with pkgs; {
enable = true;
package = i3-gaps;
extraPackages = [
rofi
i3lock
i3blocks
i3status
];
};
};
}