nix-config/nixos/_mixins/desktop/qt-style.nix
Gregory Burd 86706b1fc7 wimpy-ified
inspired by wimpysworld nix-config
2023-09-25 14:05:07 -04:00

19 lines
363 B
Nix

{ lib, pkgs, ... }: {
environment = {
systemPackages = with pkgs; [
qgnomeplatform-qt6
];
# Required to coerce dark theme that works with Yaru
# TODO: Set this in the user-session
variables = lib.mkForce {
QT_QPA_PLATFORMTHEME = "gnome";
QT_STYLE_OVERRIDE = "Adwaita-Dark";
};
};
qt = {
enable = true;
};
}