nix-config/nixos/_mixins/services/tailscale.nix
2024-05-23 15:02:20 -04:00

14 lines
306 B
Nix

{ config, pkgs, ... }: {
environment.systemPackages = with pkgs; [ tailscale ];
services.tailscale.enable = true;
networking = {
firewall = {
checkReversePath = "loose";
allowedUDPPorts = [ config.services.tailscale.port ];
trustedInterfaces = [ "tailscale0" ];
};
};
}