nix-config/nixos/server/pxe-server/disks.nix
2024-05-23 15:02:20 -04:00

30 lines
597 B
Nix

{ disks ? [ "/dev/sda" ], ... }: {
disko.devices = {
disk = {
sda = {
device = builtins.elemAt disks 0;
type = "disk";
content = {
type = "gpt";
partitions = {
boot = {
size = "1M";
# for grub MBR
type = "EF02";
};
root = {
size = "100%";
content = {
type = "filesystem";
format = "ext4";
mountpoint = "/";
};
};
};
};
};
};
};
}