nix-config/pkgs/shellcolord/default.nix
Greg Burd f3fd89af54
A fork of Misterio77 and his standard template.
Many thangs to the hard work and generous availability of:
git@github.com:Misterio77/nix-config.git
2023-09-15 10:53:38 -04:00

25 lines
628 B
Nix

{ lib, stdenv, fetchFromSourcehut }:
let
pname = "shellcolord";
in
stdenv.mkDerivation {
inherit pname;
version = "0.1";
src = fetchFromSourcehut {
owner = "~misterio";
repo = pname;
rev = "c761072952bba8bdc21b906fdc941b9ae5ac5432";
sha256 = "sha256-SLMAZy9UxQOA+2YhnryJ5ZvMXOf/Bxv0E8gIbP32XfE=";
};
makeFlags = [ "PREFIX=$(out)" ];
meta = with lib; {
description = "A daemon that themes your shell remotely";
homepage = "https://git.sr.ht/~misterio/shellcolord";
license = licenses.unlicense;
platforms = platforms.all;
maintainers = with maintainers; [ misterio77 ];
};
}