nix-config/pkgs/xpo/default.nix
Greg Burd f3fd89af54
A fork of Misterio77 and his standard template.
Many thangs to the hard work and generous availability of:
git@github.com:Misterio77/nix-config.git
2023-09-15 10:53:38 -04:00

14 lines
323 B
Nix

# Exposes a port through SSH
# xpo [local port] [remote host] [remote port]
{ lib, writeShellApplication, openssh }: (writeShellApplication {
name = "xpo";
runtimeInputs = [ openssh ];
text = builtins.readFile ./xpo.sh;
}) // {
meta = with lib; {
licenses = licenses.mit;
platforms = platforms.all;
};
}