nix-config/shells/code-format/flake.nix
2024-06-06 11:17:28 -04:00

32 lines
735 B
Nix

{
description = "Nix shell for code-format tools";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/release-24.05";
flake-utils.url = "github:numtide/flake-utils";
};
outputs =
{ nixpkgs
, flake-utils
}:
flake-utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
in
{
devShells.default = pkgs.mkShell {
packages = with pkgs; [
black # Code format Python
chroma # Code syntax highlighter
mdp # Terminal Markdown presenter
nodePackages.prettier # Code format
rustfmt # Code format Rust
shellcheck # Code lint Shell
shfmt # Code format Shell
];
};
});
}