nix-config/shells/file-sync/flake.nix
2024-06-06 11:17:28 -04:00

30 lines
672 B
Nix

{
description = "Nix shell for file sync tools";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/release-24.05";
flake-utils.url = "github:numtide/flake-utils";
};
outputs =
{ nixpkgs
, flake-utils
}:
flake-utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
in
{
devShells.default = pkgs.mkShell {
packages = with pkgs; [
croc # Terminal file transfer
mktorrent # Terminal torrent creator
rclone # Terminal cloud storage client
s3cmd # Terminal cloud storage client
zsync # Terminal file sync
];
};
});
}